Fab's AutoBackup forums

Welcome to Fab's AutoBackup technical support forums
Bienvenue sur les forums de support technique de Fab's AutoBackup
  • You are not logged in.

Announcement


Due to a large amount of fake accounts registrations for advertising purpose (spam), this forum does not accept new registrations any longer.
You can still browse existing threads to find the help you are looking for. If you do not find it and have questions, please use this contact form.

====================================

En raison d'un nombre important d'enregistrements de faux comptes utilisateurs à des fins de spam (publicité non sollicitée), il n'est désormais plus possible de s'enregistrer sur les forums de support technique.
Vous pouvez toujours parcourir les sujets existants pour trouver ce que vous recherchez. Si vous ne trouvez pas l'information et avez des questions, veuillez utiliser ce formulaire de contact.

#1 Re: Help - Fab's AutoBackup 7 Pro » Sent 2 machines out, and owners are stating their files are 0kb files? » 2022-04-25 23:31:36

Fab

I guess these files were stored on OneDrive or Dropbox right? Nowadays, OneDrive enables  the "files on demand" feature. It means that the files are online (on the "cloud") only and not physically on the drive. When Fab's try to backup them using other credentials than current user account or from a hooked drive, it will throw warnings about that and copied files could be 0kb since they could not be downloaded from the cloud. I guess this is what happened here.

#2 Re: Help - Fab's AutoBackup 7 Pro » Last few backups I'm hanging on Firefox profile ? » 2022-04-20 19:41:30

Fab
cire3pc wrote:

Oh, and a quick question.  For problem drives, any chance of getting a pause button ? To re-cycle the drive and have another go at it ?  I have PC3000, but can't use Fab with it to handle problematic drives.

That's true, there's no real "pause" button. BUT, if you click the cancel button, there will be a popup asking if you really want to abort the job. While this prompt is shown, the file copy is paused. I hope that helps !

#3 Re: Help - Fab's AutoBackup 7 Pro » Last few backups I'm hanging on Firefox profile ? » 2022-04-20 19:39:49

Fab
cire3pc wrote:

Had a few versions back, my drives are hanging on profile indexing. I noticed on Firefox and google drive ?

Just upgraded to current, new install location.

Hard drive activity is on solid, and just hangs.  Didn't know if anyone else seen this ? Hard to believe I have 2 hard drives with a freezing problem.  I use a SATA dock to SATA direct into the motherboard.  Any way to know what exactly it's hanging on ?

Does it really hang or does it finally continue the copy after some time ?
I've had a pretty old W7 machine as source today, it looked like it hanged while processing FF profile but a few minutes later I've noticed that, it just did the job like nothing happened.

#4 Re: Help - Fab's AutoBackup 7 Pro » Batch File return Error Codes -ERRORLEVEL » 2022-02-24 20:18:11

Fab

I've added the following piece of code in program close instructions :

If WarningCount=0 and ErrorCount=0 then ExitCode:=0;
If WarningCount>0 then ExitCode:=1;
If ErrorCount>0 then ExitCode:=2;

That should do the trick in next version.

#5 Re: Help - Fab's AutoBackup 7 Pro » Batch File return Error Codes -ERRORLEVEL » 2022-02-24 20:01:25

Fab
Thrakorzog wrote:

I would like to get the exit codes so that I could flag any failures programmatically as I run the script.

So something like:
/batchFile.cmd
AutobackupPro7.exe [commandline stuff]
If %ERRORLEVEL%==2 Echo Bad Thing 2 happened | GOTO END
If %ERRORLEVEL%==1 Echo Bad Thing 1 happened | GOTO END
If %ERRORLEVEL%==0 Echo Good Thing happened | GOTO END

:END

I'll look into it an try to add it in a next version

#6 Re: Help - Fab's AutoBackup 7 Pro » Nirsoft downloads failing » 2021-12-07 21:02:58

Fab

With this version, Nirsoft tools are inside password protected zip archives. This way, anti malware tools cannot detect it while they're in their folders.

#7 Re: Help - Fab's AutoBackup 7 Pro » Nirsoft downloads failing » 2021-12-07 17:55:27

Fab

it looks like your firewall (or anti malware maybe ?) is preventing Fab's from reaching website to download the tools.
There's an easy workaround for that : download full Fab's AutoBackup package. Nirsoft tools are now bundled in it.
Download instructions are there : https://download.fpnet.fr/Download-Update-Guide.pdf
Extract the files (by default, they go to C:\Fab's AutoBackup 7 Pro" folder) and overwrite the ones you already have with them.

#8 Re: Help - Fab's AutoBackup 7 Pro » Feature Request. » 2021-12-01 19:34:21

Fab
Grinch843 wrote:

Hi, would be nice to have an option that would let us hide items on the selection screens that are not found.

At least I can try. However, I may have to remove resize ability. Now, each item is placed on the interface regarding other items placement. Each position is hard coded so, I would have to develop something more "dynamic". That will be a lot of work but I'll try it anyway.

#9 Re: Help - Fab's AutoBackup 7 Pro » FABS not allowing to restore from backup config file » 2021-11-17 10:47:59

Fab

I've worked to solve that issue. Now, at backup, if it copies an additional file, it will add it to a text file list. At restore, the program will load this list instead of using a file search. This way, if there is a large amount of additional files, it will list them way faster. If that list does not exist (if the backup has been made with a previous Fab's version), it will show what it is doing instead of doing its thing in background. The program should not look stuck anymore with this.
This will be in the next update. Stay tuned !

#10 Re: Help - Fab's AutoBackup 7 Pro » Error message "This app can't run on your PC" » 2021-11-15 14:47:35

Fab
stuartmc wrote:

Thank you

Is your problem solved? If so, what did you do ?

#11 Re: Help - Fab's AutoBackup 7 Pro » Error message "This app can't run on your PC" » 2021-11-15 13:38:13

Fab

There are 2 possibilities :
- The computer is running Windows 10 in S mode. In this case, it is impossible to run any app that does not come from the Windows Store. If that's the case, then, it must be connected to a microsoft account and S mode has to be removed from the Windows store app. Here's how to do that : https://support.microsoft.com/en-us/win … 1bfb28a307
- The program is corrupted. This can be caused by a lot of things. To sort this out, it's better to re-download the program from the Fab's AutoBackup website and try again.

#12 Re: Help - Fab's AutoBackup 7 Pro » FABS not allowing to restore from backup config file » 2021-11-11 18:21:16

Fab

So, the culprit was an "additional files" backup that was very large (lots of files) probably using file search on the entire drive. At restore, it uses file search inside backup folder to list them it looks totally stuck at that time. In fact, it is working in background and if it is let long enough, it finally goes forward.
This is something I could reproduce on my development machine.
As a workaround, use windows file explorer to browse public backup archive folder, rename the "AdditionalFiles" to something else like "AdditionalFiles-", go deeper in folders to "Public\archive\AdditionalFiles-\Data\!" folder and drag content to the new machine.
Then, use Fab's Autobackup to restore the other stuff.
I'm working on a way to fix this wink

While I was on this computer, I thought there was also a problem if there was a space in the user name but finally not as I tried to reproduce such a weirdness as well but nothing happened.

#13 Re: Help - Fab's AutoBackup 7 Pro » FABS not allowing to restore from backup config file » 2021-11-11 16:39:12

Fab

I got your message but I don't know if you got my reply.
You can choose either TeamViewer or Anydesk. Both are fine for me.

#14 Re: Help - Fab's AutoBackup 7 Pro » FABS not allowing to restore from backup config file » 2021-11-11 16:21:52

Fab
schwags wrote:

I recently updated my FABS to the newest version but this is also happening on older versions as well, but the last two out of 3 times I've tried to "restore" from my backup that I made via the config file, it freezes after pressing the "next" button - the english/language drop-down bar blinks and disappears and nothing happens.  It doesn't freeze up the application, because I can move it and it's still responsive but nothing happens.  Any thoughts?

Thanks.

No idea right now. However, I could remote in that system and try to guess what's going on.
Please send me how to get in this system on my email "fab [at ] fpnet [dot] fr"

#15 Re: Help - Fab's AutoBackup 7 Pro » Help, what does this mean please? » 2021-07-02 15:04:07

Fab
EasyPC wrote:

Yes it's failing, I have it mounted through a rapidspar recovery device. Hopefully done by the end of the weekend smile

Good luck on this one

#16 Re: Help - Fab's AutoBackup 7 Pro » Help, what does this mean please? » 2021-06-30 17:59:13

Fab
EasyPC wrote:

I have a huge (or more accurately, very slow) backup running that may take a day or two

A day or two !!!  yikes
That's crazy! Poor condition source drive maybe ?
I hope you are not backing up to some USB thumb drive right? Those can be excessively slow.

#17 Re: Help - Fab's AutoBackup 7 Pro » Help, what does this mean please? » 2021-06-30 16:00:49

Fab

It definitely sounds like a network issue IMHO

#18 Re: Help - Fab's AutoBackup 7 Pro » Help, what does this mean please? » 2021-06-30 14:47:23

Fab

Testing right now. Some source paths are longer than 300 chars. Target paths will be even longer.
Will report here if that's the issue or not.

Edit : test has just finished with no error. Longest target UNC path is 362 chars so that's not the problem at all.

#19 Re: Help - Fab's AutoBackup 7 Pro » Help, what does this mean please? » 2021-06-30 12:39:42

Fab
EasyPC wrote:

Oddly I mapped the network drive and it's working smile

Perhaps something with long paths ?
Using a mapped drive makes the path shorter.
It's not supposed to be a concern anymore but I need to try anyway with long files paths against with a UNC path as target. Just in case...

#20 Re: Help - Fab's AutoBackup 7 Pro » Help, what does this mean please? » 2021-06-30 12:18:31

Fab

Hi,
It sends such a prompt message if target file does not exist on network storage.
This can happen if network connection drops.

#21 Re: Help - Fab's AutoBackup 7 Pro » Unable to update product using link on main window » 2021-06-17 07:01:01

Fab

Yes, it's still broken with 7.6.2.3791.
There's still a conflict between main app not releasing txt control file and updater that tries to create the same file. 7.7.4119 uses a different file name so there should not be such an issue with it. You need to go with full package instead (again...).
Sorry about that!

#22 Re: Help - Fab's AutoBackup 7 Pro » Feature Request - Backup HMRC PAYE Tools » 2021-05-27 14:14:21

Fab

Hi Andy,
I guess this is quite popular in the UK but probably not worldwide. Anyway, that should be easy to do.
I'll look at it !

Edit : it's in the new code. That will be part of next update but it will not be released that soon as I'm doing some tricky changes in Fab's. I'll do my best wink

#23 Re: Help - Fab's AutoBackup 7 Pro » When selecting additional folder, subfolders are no longer selected » 2021-04-30 20:44:45

Fab
xochipilli wrote:

I guess I will end removing that check tree view that is dodgy since the very beginning.

That's why I check if the subdirs are checked as well smile

Work started today. That would be a bit different than what I said in my previous post. There would be a tree view (without check boxes) on the left side and a list with check boxes on the right side. I'll do my best to make that as handy as possible despite the fact check boxes in the tree view will disappear

#24 Re: Help - Fab's AutoBackup 7 Pro » When selecting additional folder, subfolders are no longer selected » 2021-04-29 15:58:20

Fab
xochipilli wrote:

Well, tested again on other machine, it did copy the folder i selected (even though the cosmetic issue is confusing)
But something seems to be not right anyway, i did a few tries and at times folders i de-selected were still backupped etc... I keep you posted if I can make some sense of it or if the problems persist.
Thanks for your quick answers, as always..

I guess I will end removing that check tree view that is dodgy since the very beginning.
I thik about a simple tree view on the left side and 2 lists views on the left. One for folders including subfolders and the other for folders content only. This way, no more hassle

#25 Re: Help - Fab's AutoBackup 7 Pro » When selecting additional folder, subfolders are no longer selected » 2021-04-29 15:10:32

Fab
xochipilli wrote:

That section is only there when i select an additional folder and then quit the program
But it makes not difference if the section is removed afterwards, the problem remains when I try it again

I've just tested it right now and it worked as expected. However, there's a cosmetic issue here anyway : As soon as folder is selected while it's collapsed, sub folders will be copied as well. The problem is that when you expand it after you selected it while collapsed, sub folders show as unselected while they are in fact.
Edit: if you need, I can provide a download link to the last version that was available before your update period has expired. Let me know.

Board footer