Fab's AutoBackup forums

Welcome to Fab's AutoBackup technical support forums
Bienvenue sur les forums de support technique de Fab's AutoBackup
  • You are not logged in.

#1 2017-09-01 13:59:12

Modjo
Member
Registered: 2017-09-01
Posts: 16

BUG documents non récupérés

Bonjour

Déjà, merci pour ce log bien pratique.

Le Windows ne démarrait pas. Le client avait un raccourci mes documents sur le bureau. J’ai récupéré les données avec Autobackup 6pro basé sur WinPE Windows 10 1607 sur un PC Windows 10 (1703 je suppose).
J’ai formaté et installé Windows 10 1703 64 bits. J’ai restauré les données avec Autobackup 6 pro à jour (application bureau). Le dossier mes documents est vides. Le raccourci mes documents sur le bureau indique si on clic dessus « le chemin réseau n’existe pas ».
Plein de documents importants sont perdus, j’ai perdu le client avec. Je me dis, c'est peut-être réellement sur le réseau.

Quelques mois plus tard idem pour un autre client dont le Windows démarre pas. Cette fois par précaution j’avais refait mes Autobackup (bureau et WinPE), fait un clone, et bien vérifier que la case mes documents étaient cochés. Le clone contient bien les fichiers du dossier document, mais pas Autobackup. Le client a aussi un raccourci qui mène vers mes documents sur le bureau qui indique si on clic dessus « le chemin réseau n’existe pas ».

Dans les deux cas, tous le reste est bien recupéré, ça ne concerne que le dossier mes documents
;)

Last edited by Modjo (2017-09-01 14:08:41)

Offline

#2 2017-09-01 19:36:39

Fab
Administrator
Registered: 2011-05-11
Posts: 1,212

Re: BUG documents non récupérés

Bonjour,

je suis assez surpris car personne ne m'a jamais rapporté un tel problème. Je suis toutefois en train de compiler un nouveau Win10PE embarquant la dernière version de Fab's AutoBackup 6 pro afin de faire de nouveaux tests.
Juste au cas où, le plugin pour Win10PE a été mis à jour. Je vous suggère de le récupérer ici (clic droit, puis enregistrer sous) et de remplacer celui que vous avez déjà : http://download.fpnet.fr/winpe/Fabs_Aut … _V7.script
Concernant le compte utilisateur, c'était un compte local ou Microsoft?

Edit : j'ai pu faire le test. J'ai compilé mon Win10PE à partir d'un média Windows 10 1607 (anniversary update) et je l'ai utilisé sur un compte local ainsi qu'un compte Microsoft sur une machine sous Windows 10 1704 (creators update). Dans les deux cas, les documents ont bien été copiés dans l'archive de Fab's AutoBackup.


Fab

Offline

#3 2017-09-02 00:21:47

Modjo
Member
Registered: 2017-09-01
Posts: 16

Re: BUG documents non récupérés

Je sais pas si c'etait des comptes locals ou microsoft

Ça marche chez moi avec les autres recuperations, recupe avec la win pe sur windows qui demmare (virus) et restauré avec la version desktop. La particularité des fois ou ça buggé c'est le fait que dans les deux cas il y ait un raccourci vers mes documents sur le bureau et qu’il y ai l’erreur « le chemin réseau n’existe pas » ou un truc du genre. Et aussi que dans les deux cas, le Windows d’origine ne démarrait pas.
Il y a la preuve que les documents ne sont pas sur le reseau car ils sont dans le clone.

Last edited by Modjo (2017-09-02 00:36:04)

Offline

#4 2017-09-02 09:44:07

Fab
Administrator
Registered: 2011-05-11
Posts: 1,212

Re: BUG documents non récupérés

Il se trouve que le PE affiche des "raccourcis" erronés (les cibles sont d'anciens chemins comme "C:\Docuements and settings\Utilisateur\Mes documents"). Je suppose que Microsoft les a laissés pour des raisons de compatibilité avec d'anciens programme conçus pour Windows XP par exemple. Ils ne pointent pas vers des emplacements qui existent vraiment sur les Windows d'aujourd'hui. Ce raccourci "mes documents" qui apparait chez vous sur le bureau peut sans problème être supprimé. Je peux éventuellement voir si je ne peux pas éviter sa copie en premier lieu mais ça ne va pas être évident à faire car comment savoir si tel ou tel raccourci n'a pas été placé sur le bureau par l'utilisateur? Je vais tâcher d'aller plus loin dans mes recherches mais ça risque de me demander du temps car je suis loin des mes machines de développement et m'y connecter à distance pour faire des tests est assez sportif du fait d'une connexion instable.
Je vais donc essayer de refaire les mêmes sauvegardes qu'hier en mode PE, suivies cette fois d'une restauration vers de nouveaux comptes utilisateurs histoire de voir comment tout cela se comporte et surtout d'envisager une approche pour traiter le problème si j'arrive à le reproduire.


Fab

Offline

#5 2017-09-02 12:26:23

Modjo
Member
Registered: 2017-09-01
Posts: 16

Re: BUG documents non récupérés

Les raccourcis en question avaient été créés par les utilisateurs.

Je ne suis pas pressé, j'informe juste. En attendant, je vérifiais toujours les documents et ferais une copie à la main si nécessaire. Tout en invitant les clients à prendre une sécurité (facturé) en plus. À savoir deux copies, faites sur deux disques durs distincts avec des logiciels différents.

Last edited by Modjo (2017-09-02 12:33:26)

Offline

#6 2017-09-04 10:00:44

Fab
Administrator
Registered: 2011-05-11
Posts: 1,212

Re: BUG documents non récupérés

Modjo wrote:

Les raccourcis en question avaient été créés par les utilisateurs.

Je n'ai pas encore eu le temps de me repencher sur cette affaire. Cependant, je pense que si l'utilisateur avait créé son raccourci vers "mes docuement", il suffit que le compte utilisateur soit différent à la restauration pour que la cible du raccourci ne soit plus valide, d'où le message d'erreur indiquant que le chemin n'existe pas. Cela n'est pas bien grave si les documents sont bel et bien présents dans le profil utilisateur à l'emplacement C:\Users\Utilisateur\Documents
Il suffit alors soit de modifier la cible du raccourci, soit de le recréer.


Fab

Offline

#7 2017-09-04 10:51:04

Modjo
Member
Registered: 2017-09-01
Posts: 16

Re: BUG documents non récupérés

Malheureusement les documents ne sont pas présents dans C:\Users\Utilisateur\Documents alors que dans le clone ils y sont, (car l'image est nettement plus grosse.)

Offline

#8 2017-09-04 10:56:09

Fab
Administrator
Registered: 2011-05-11
Posts: 1,212

Re: BUG documents non récupérés

Auriez-vous la possibilité de faire un essai avec les dernière version du plugin pour Win10 PE ? Il se trouve qu'un outil Microsoft permettant de prendre possession des fichiers et dossiers n'était pas copié sur le PE avec la précédente version dans le cas d'un PE 64bits. En y repensant, je suis persuadé que vous ayez eu affaire à ce type de problème. Dans le cas d'un compte utilisateur protégé par mot de passe, le programme ne pouvait alors pas s'attribuer les droits nécessaires à la copie des fichiers, d'où leur absence de sauvegarde. Je vous suggère donc de recompiler un PE avec cette version du plugin afin que tous les composants nécessaires au bon fonctionnement du programme soient bien présents.


Fab

Offline

#9 2017-09-04 13:15:06

Modjo
Member
Registered: 2017-09-01
Posts: 16

Re: BUG documents non récupérés

Pourtant ça recuperé le reste du dossier user, les photos, le bureau ...

Non, je ne peux pas refaire le test les clients on recuperé leurs PC. Je mettrais a jour prochainement.

Offline

#10 2017-09-04 13:21:10

Fab
Administrator
Registered: 2011-05-11
Posts: 1,212

Re: BUG documents non récupérés

Modjo wrote:

Pourtant ça recuperé le reste du dossier user, les photos, le bureau ...

Je suspecte Windows d'être un peu moins permissif avec les documents qu'avec le reste. Par exemple, je me suis heurté par le passé à des difficultés d'accès aux documents d'un disque dur sous Windows XP que j'avais monté dans une autre machine. J'avais bien accès au reste comme le bureau et autres mais pour les documents (qui contenaient également photos, musique et autres d'ailleurs), c'était une autre histoire! Il m'avait alors fallu redéfinir les droits d'accès manuellement par prise de possession (changement du propriétaire du dossier) puis la redéfinition des autorisations pour pouvoir y accéder.


Fab

Offline

#11 2017-09-04 13:52:06

Modjo
Member
Registered: 2017-09-01
Posts: 16

Re: BUG documents non récupérés

OK, ouai ba ça doit etre ça alors.

Offline

Board footer